書類(PDFファイル)のタイムスタンプをAcrobat Readerで確認した際に、タイムスタンプや署名は有効ですが、「署名に問題があります」と表示される場合があります。
原因と対処方法について解説します。
ご注意
ご利用のAcrobat Readerのバージョンにより、操作内容が異なる場合があります。
原因
タイムスタンプの証明書がAcrobat Readerに信頼されていないためです。署名自体が壊れているわけではなく、Acrobat Reader側の設定や証明書の登録不足が原因で警告が出ます。
対処方法1
以下の方法で、Acrobat Readerの設定変更を行います。
- Acrobat Readerで 「メニュー」 > 「環境設定」をクリックします。
2. 分類で「署名」を選択し、「検証」の[詳細]をクリックします。
3. 「Windows統合」のチェックボックス2つにチェックを入れ、[OK]をクリックします。
4. 分類で「信頼性管理マネージャー」を選択し、「Adobe AATLサーバーから信頼済み証明書を読み込む」にチェックを付け、[今すぐ更新]をクリックします。
※ 「Adobe AATLサーバーから信頼済み証明書を読み込む」にチェックがついていた場合は、チェックを外し、再度付け直してください。
5. 「セキュリティは正常に更新されました」というダイアログが表示されたら、[OK]をクリックします。「環境設定」画面でも、[OK]をクリックします。
6. [署名パネル]をクリックします。
7. 三点リーダーをクリックし、「文書内のすべての署名を検証」をクリックします。
8. 以下のダイアログが表示されたら、[OK]をクリックします。
9. 「すべての署名の検証を完了しました。」というダイアログが表示されたら、[OK]をクリックします。
10. 書類(PDFファイル)を一度閉じ、再度開き直します。「署名に問題があります」という表示が消えたことをご確認ください。
対処方法2
前述の「対処方法1」で解消されない場合、以下の操作をお試しください。
1. 以下より、ルート証明書「Security Communication RootCA3 Certificate(SCRoot3ca.cer)」をダウンロードします。
https://repository.secomtrust.net/SC-Root3/ (外部サイト)
2. 以下より、CA証明書「SECOM TimeStamping CA3 Issuer:Security Communication RootCA3」をダウンロードします。
https://repo1.secomtrust.net/spcpp/ts/ (外部サイト)
3. Acrobat Readerで 「メニュー」 > 「環境設定」をクリックします。
4. 分類で「署名」を選択し、「IDと信頼済み証明書」の[詳細]をクリックします。
5. 「デジタルIDと信頼済み証明書の設定」が開きます。「信頼済み証明書」を選択し、[取り込み]をクリックします。
6. [参照]をクリックし、ダウンロードした証明書を1つ選択し、[開く]をクリックします。もう1つの署名書も同じ手順で選択します。
7. [取り込み]をクリックします。
8. 「取り込みの終了」のダイアログが表示されたら、[OK]をクリックします。
9. 「SECOM TimeStamping CA3」を選択し、[信頼性を編集]をクリックします。
10. 「この証明書を信頼済みのルートとして使用」にチェックを付け、[OK]をクリックします。
11. 「Security Communication RootCA3」も、手順「9.」「10.」と同様に操作します。
12. 「デジタルIDと信頼済み証明書の設定」を閉じます。「環境設定」画面で、[OK]をクリックします。
13. 書類(PDFファイル)を一度閉じ、再度開き直します。「署名に問題があります」という表示が消えたことをご確認ください。