Acrobat Readerで署名を検証した際に「検証にエラーが1つ以上あります。」と表示される場合があります。原因と対処方法について解説します。
原因
Adobe Approved Trust List(信頼済み証明書のリスト)の署名情報が正しく更新できていない可能性があります。
署名情報を更新しても改善しない場合は、ネットワーク設定が原因となっているケースがあります。特に、Allow List(許可リスト)に必要な接続先が追加されていないと、Adobe Approved Trust Listの自動更新や証明書の失効情報取得が正常に行えません。
対処方法
以下のURLが社内ネットワークのファイアウォールやプロキシによってブロックされていないかをご確認ください。必要に応じてアクセス許可設定に追加してください。
Adobe Approved Trust List更新時の接続先
https://trustlist.adobe.com (外部サイト)
本システムの電子署名用証明書関連の失効情報
- https://repo1.secomtrust.net/spcpp/pfm20pub/aatlrsaca2023/aatlrsaca2023.crl (外部サイト)
- https://repo1.secomtrust.net/root/docrsa/docrsarootca2023.crl (外部サイト)
タイムスタンプ証明書関連の失効情報
- http://repository.secomtrust.net/SC-Root3/SCRoot3CRL.crl (外部サイト)
- http://repo1.secomtrust.net/spcpp/ts/ca3/fullCRL.crl (外部サイト)
- http://ts3.ocsp.secomtrust.net (外部サイト)
- http://scrootca3.ocsp.secomtrust.net (外部サイト)
これらのURLへのアクセスを許可することで、署名の検証エラーが改善する可能性があります。